Archive

Posts Tagged ‘linux’

/dev/video0 permission problem : problema webcam en Ubuntu Koala

12 marzo, 2010 1 comentario

/dev/video0 permission problem : problema webcam en Ubuntu Koala

  1. Bug #488455

No me gustó el Karmic. Desde un principio me dió “mala espina” y con el tiempo la aparición de un multitud de defectos de configuración, produjo que me arrepintiese de haber upgrade desde el Ibex.

Uno de los problemas o de lo que dejó de funcionar, fue la camaraweb. Ni con el cheese, ni con cualquier otro salía la imagen. En /dev/ aparecía, por tanto el sistema la cargaba y tenía los driver (gspca, creo). Un día descubrí que desde la consola con privilegios de root, podía usar la cámara. Cosa sorprendente.

Después empezó el problemas de los navegadores. Arrancando el chrome desde Root podía hacer uso de la cámara en la red a través de Adobe Flash. Pero el firefox era un caos, como root me decía que no tenía el Flash instalado .

Lo que más me gusta de linux, es que todo es cuestión de tiempo. Así que de vez en cuando repasaba foros, comunidad y etc, buscando solución al problema “no me funciona la cámara web”. Localicé además que el problema debía ser el acceso a “/dev/video0”, ya que el selector de sistema multimedia me confirmaba que no se poseían derechos para manejar “video0”. Bueno, probé todo cambiar permisos, cambiar usuarios, cambiar grupos, y “nasti de plastic”.

Pero la semana pasada descubrí en la comunidad el Bug #488455. La historia es algo así como que cuando se conecta la cámara (en este caso una usb) se crea un archivo de permisos en /dev/shm/usb-* que establece quien pude operar con el periférico. De tal manera, que si los propietarios de estos archivos (usb-*) son los administradores, por mucho que queramos no podrá acceder a ese dispositivo ningún otro usuario.

Así que la solución era muuuy fácil. Cambias el propietario de /dev/shm/usb-* al usuario deseado, y “ya está”. CámaraWeb completamente operativa.

Categorías:Linux-Ubuntu Etiquetas: , ,

Unable to get gail version number: el OpenOffice no arranca

7 junio, 2009 Deja un comentario

iaenus@iaenus-laptop:~$ oowriter

** (soffice:5741): WARNING **: unable to get gail version number

iaenus@iaenus-laptop:~$ sudo mv ~/.openoffice.org* /tmp

[sudo] password for iaenus:

iaenus@iaenus-laptop:~$ oowriter

Después de instalar la extensión Sun Weblog Publisher se me colgó el Ooo. Los problemas con gail version number están registrados en Launchpad ( Bug #365763). Pues la solución es muy parecida a la de cuelgues del gnome, eliminar los archivos de configuración del Ooo. Se pierden evidentemente las extensiones instaladas, archivos recientes, y todo tipo de datos. Pero la instalación no.

Aunque la integración entre Ooo y WP parece bastante chula. Incluso se pueden editar entradas desde el Ooo.

Categorías:Linux-Ubuntu, Varia Etiquetas: , ,
A %d blogueros les gusta esto: